Android Kotlin-android-extensions警告

此文以下方警告訊息,做開頭介紹
The ‘Kotlin-android-extensions’ Gradle plugin is deprecated. Please use this migration guide (https://goo.gle/kotlin-android-extensions-deprecation) to start work with View Binding (https://developer.android.com/topic/libraries/view-binding) and the ‘kotlin-parcelize’ plugin.

1. 升級ext.kotlin_version = “1.5.0″發生警告

2. 如何處理警告訊息?

1. 升級ext.kotlin_version = “1.5.0″發生警告?

在Android Studio3.6版本後
當時測試設定成ext.kotlin_version = “1.5.0″版本,會出現警告提示
不推薦使用kotlin-android-extensions,遷移至kotlin-parcelize

2. 如何處理警告訊息?

kotlin-android-extensions轉換成kotlin-parcelize方法
1.打開App bundle.gradle
a.刪掉apply plugin: ‘kotlin-android-extensions’
b.新增apply plugin: ‘kotlin-parcelize’
d.有引用到import kotlinx.android.parcel.Parcelize
更改為import kotlinx.parcelize.Parcelize
這樣就完成了庫的替換,警告也會消失囉


訂閱Codeilin的旅程,若有最新消息會通知。

廣告

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com 標誌

您的留言將使用 WordPress.com 帳號。 登出 /  變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 /  變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 /  變更 )

連結到 %s

WordPress.com.

向上 ↑

%d 位部落客按了讚: